Bonjour à tous !

J'ai un soucis sur Symfony 5.4.10 que je n'arrive pas à régler :

Tous mes assets semblent ne pas trouver leur chemin alors que l'affichage se fait correctement en localhost (les css s'appliquent, les images s'affichent, etc.)

Par exemple pour :

    <link rel="stylesheet" href="{{ asset('css/bootstrap.css') }}">
    <link rel="stylesheet" href="{{ asset('css/style.css') }}">
    <script src="{{ asset('js/script-img-fix.js') }}"></script>
    <img src="{{ asset('img/Logo.png') }}" alt="Logo">

Ce que je veux

J'aimerais que mon repertoire public soit correctement localisé pour que mon code s'affiche normalement

Ce que j'obtiens

Tout ce qui est entre les quotes de l'asset 'css/bootstrap.css', 'css/style.css', etc. est surligné en jaune et au survole ça m'affiche "Missing asset"

Je suis totalement novice sur Symfony. J'ai cherché la solution partout et ai tenté toutes les manip trouvées sur divers forum mais rien n'y fait je ne trouve pas ou ne comprends tout simplement pas les manip à faire...

Merci beaucoup de votre aide !!!

11 réponses


Hello, pas sûr de comprendre ton problème : tes assets sont bien loadées au rendu de la page, mais ton IDE / éditeur de texte ne comprends pas ces url et t'affiche un warning ?

wanda
Auteur

Salut Glioburd merci de ta réponse !
Oui c'est exactement ça. J'ai trouvé sur quelques forums des personnes qui avaient aussi ce problème mais je ne comprends pas la manip pour corriger le problème.
Par exemple :
https://github.com/Haehnchen/idea-php-symfony2-plugin/issues/1020

Dans ce cas précise au départ quel logiciel tu utilise :D
J'imagine que tu utilise PhpStorm ? Tu as installé le plugin Symfony ?

wanda
Auteur

pardon oui ! je suis sur PhpStorm et plugin Symfony installé of course :)

wanda
Auteur

Salut à tous ! est-ce que quelqu'un peut m'aider ?
Merci beaucoup !

wanda
Auteur

Salut !
Est-ce que quelqu'un comprend mon problème de Missing asset ? veut bien me venir en aide ?
Merci d'avance !

Bonjour wanda.

J'espère que ça t'aidera.
-Tu as bien twig d'installer ?
-Tu peux tenter de faire un "composer install" un package a peux éventuellement ne pas être installé même si il se trouve dans ta config "composer.json"

  • Il t'indique un mauvais chemin, mais quel chemin te propose t-il ?

Le meilleure moyen reste d'utiliser la documentation
https://symfony.com/doc/5.4/templates.html#linking-to-css-javascript-and-image-assets

Hello, si tu places ton curseur au milieux de la partie souslignée en jaune et que tu fait Alt+Entrer, tu as une option pour ajouter un support (enable support for... ou un truc du genre)

wanda
Auteur

Bonjour SiProdZz et popotte merci de vos réponses !

@SiProdZz
Je viens d'essayer avec composer require symfony/asset mais ça n'a pas réglé mon problème après redémarrage de Symfony, mes chemins sont toujours en jaune.
Je précise que tous les chemins sont en jaune : les css, les js, les images et même les ancres.

@popotte
Si je me mets sur mon Missing asset en faisant Alt+Entrer, Symfony me propose d'inspecter l'erreur mais ne suggère pas de réédition du lien comme il le fait d'habitude...

J'ai fait des captures d'écran mais ne sais pas comment vous les montrer.

Je précise aussi qu'en local tout s'affiche sans problème, c'est donc qu'il a bien compris où vont mes liens...!

Ah non ce n'est pas l'option rééditin qui est à rechercher, parce que concrètement ton lien est bon, en gros il fallait une option "enable support for" ou un truc du genre ^^

Alors pour les captures, tu héberges tes images dans un hébergeur d'images, et ensuite tu envoies le lien :p

Tu as quoi comme plugins lié à Symfony? (déjà tu as Symfony, et quoi d'autre?)

Montre nous ton fichier composer.json