Bonjour,

J'ai un problème avec l'installation de symfony 4, à chaque fois il fait la même erreur.

Je préciser que mon projet est hébergé sur une offre mutualisé pro de ovh sur lequel composer n'est pas installé de base, je l'ai donc rajouté ce qui explique le php composer.phar à la place du composer.

Ce que je fais

J'essaye d'installer symfony avec

php composer.phar create-project symfony/website-skeleton symfony1

Ce que j'obtiens

voici les informations d'installation ainsi que l'erreur tout à la fin


Installing symfony/website-skeleton (v4.1.7.8)
  - Installing symfony/website-skeleton (v4.1.7.8): Loading from cache
Created project in symfony1
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Package operations: 94 installs, 0 updates, 0 removals
  - Installing ocramius/package-versions (1.3.0): Loading from cache
  - Installing symfony/flex (v1.1.7): Loading from cache
  - Installing symfony/polyfill-mbstring (v1.10.0): Loading from cache
  - Installing doctrine/lexer (v1.0.1): Loading from cache
  - Installing doctrine/annotations (v1.6.0): Loading from cache
  - Installing doctrine/reflection (v1.0.0): Loading from cache
  - Installing doctrine/event-manager (v1.0.0): Loading from cache
  - Installing doctrine/collections (v1.5.0): Loading from cache
  - Installing doctrine/cache (v1.8.0): Loading from cache
  - Installing doctrine/persistence (v1.0.1): Loading from cache
  - Installing doctrine/inflector (v1.3.0): Loading from cache
  - Installing doctrine/common (v2.9.0): Loading from cache
  - Installing symfony/doctrine-bridge (v4.1.7): Loading from cache
  - Installing doctrine/doctrine-cache-bundle (1.3.5): Loading from cache
  - Installing doctrine/instantiator (1.1.0): Loading from cache
  - Installing symfony/console (v4.1.7): Loading from cache
  - Installing zendframework/zend-eventmanager (3.2.1): Loading from cache
  - Installing zendframework/zend-code (3.3.1): Loading from cache
  - Installing ocramius/proxy-manager (2.1.1): Loading from cache
  - Installing doctrine/dbal (v2.8.0): Loading from cache
  - Installing doctrine/migrations (v1.8.1): Loading from cache
  - Installing egulias/email-validator (2.1.6): Loading from cache
  - Installing jdorn/sql-formatter (v1.2.17): Loading from cache
  - Installing phpdocumentor/reflection-common (1.0.1): Loading from cache
  - Installing phpdocumentor/type-resolver (0.4.0): Loading from cache
  - Installing psr/cache (1.0.1): Loading from cache
  - Installing psr/container (1.0.0): Loading from cache
  - Installing psr/simple-cache (1.0.1): Loading from cache
  - Installing symfony/http-foundation (v4.1.7): Loading from cache
  - Installing symfony/event-dispatcher (v4.1.7): Loading from cache
  - Installing psr/log (1.0.2): Loading from cache
  - Installing symfony/debug (v4.1.7): Loading from cache
  - Installing symfony/http-kernel (v4.1.7): Loading from cache
  - Installing symfony/routing (v4.1.7): Loading from cache
  - Installing symfony/finder (v4.1.7): Loading from cache
  - Installing symfony/filesystem (v4.1.7): Loading from cache
  - Installing symfony/dependency-injection (v4.1.7): Loading from cache
  - Installing symfony/config (v4.1.7): Loading from cache
  - Installing symfony/cache (v4.1.7): Loading from cache
  - Installing symfony/framework-bundle (v4.1.7): Loading from cache
  - Installing sensio/framework-extra-bundle (v5.2.2): Loading from cache
  - Installing symfony/asset (v4.1.7): Loading from cache
  - Installing symfony/expression-language (v4.1.7): Loading from cache
  - Installing symfony/inflector (v4.1.7): Loading from cache
  - Installing symfony/property-access (v4.1.7): Loading from cache
  - Installing symfony/options-resolver (v4.1.7): Loading from cache
  - Installing symfony/intl (v4.1.7): Loading from cache
  - Installing symfony/polyfill-intl-icu (v1.10.0): Loading from cache
  - Installing symfony/form (v4.1.7): Loading from cache
  - Installing monolog/monolog (1.24.0): Loading from cache
  - Installing symfony/monolog-bridge (v4.1.7): Loading from cache
  - Installing doctrine/orm (v2.6.2): Loading from cache
  - Installing doctrine/doctrine-bundle (1.9.1): Loading from cache
  - Installing doctrine/doctrine-migrations-bundle (v1.3.1): Loading from cache
  - Installing symfony/orm-pack (v1.0.5): Loading from cache
  - Installing symfony/security (v4.1.7): Loading from cache
  - Installing symfony/security-bundle (v4.1.7): Loading from cache
  - Installing symfony/serializer (v4.1.7): Loading from cache
  - Installing symfony/property-info (v4.1.7): Loading from cache
  - Installing webmozart/assert (1.3.0): Loading from cache
  - Installing phpdocumentor/reflection-docblock (4.3.0): Loading from cache
  - Installing symfony/serializer-pack (v1.0.1): Loading from cache
  - Installing swiftmailer/swiftmailer (v6.1.3): Loading from cache
  - Installing symfony/swiftmailer-bundle (v3.2.4): Loading from cache
  - Installing symfony/translation (v4.1.7): Loading from cache
  - Installing symfony/validator (v4.1.7): Loading from cache
  - Installing psr/link (1.0.0): Loading from cache
  - Installing fig/link-util (1.0.0): Loading from cache
  - Installing symfony/web-link (v4.1.7): Loading from cache
  - Installing symfony/yaml (v4.1.7): Loading from cache
  - Installing symfony/process (v4.1.7): Loading from cache
  - Installing facebook/webdriver (1.6.0): Loading from cache
  - Installing symfony/polyfill-php72 (v1.10.0): Loading from cache
  - Installing symfony/var-dumper (v4.1.7): Loading from cache
  - Installing twig/twig (v2.5.0): Loading from cache
  - Installing symfony/twig-bridge (v4.1.7): Loading from cache
  - Installing symfony/web-profiler-bundle (v4.1.7): Loading from cache
  - Installing symfony/twig-bundle (v4.1.7): Loading from cache
  - Installing symfony/stopwatch (v4.1.7): Loading from cache
  - Installing symfony/profiler-pack (v1.0.3): Loading from cache
  - Installing symfony/monolog-bundle (v3.3.1): Loading from cache
  - Installing symfony/debug-bundle (v4.1.7): Loading from cache
  - Installing easycorp/easy-log-handler (v1.0.7): Loading from cache
  - Installing symfony/debug-pack (v1.0.6): Loading from cache
  - Installing symfony/dom-crawler (v4.1.7): Loading from cache
  - Installing symfony/dotenv (v4.1.7): Loading from cache
  - Installing nikic/php-parser (v4.1.0): Loading from cache
  - Installing symfony/maker-bundle (v1.9.0): Loading from cache
  - Installing symfony/phpunit-bridge (v4.1.7): Loading from cache
  - Installing symfony/browser-kit (v4.1.7): Loading from cache
  - Installing symfony/panther (v0.2.0): Loading from cache
  - Installing symfony/css-selector (v4.1.7): Loading from cache
  - Installing symfony/test-pack (v1.0.4): Loading from cache
  - Installing symfony/web-server-bundle (v4.1.7): Loading from cache
Generating autoload files
ocramius/package-versions:  Generating version class...
ocramius/package-versions: ...done generating version class
Symfony operations: 13 recipes (0b656448b7544d47ff8e9c3923034e10)
  - Configuring symfony/framework-bundle (>=v4.1.7): From auto-generated recipe
  - Configuring doctrine/doctrine-cache-bundle (>=1.3.5): From auto-generated recipe
  - Configuring sensio/framework-extra-bundle (>=v5.2.2): From auto-generated recipe
  - Configuring doctrine/doctrine-bundle (>=1.9.1): From auto-generated recipe
  - Configuring doctrine/doctrine-migrations-bundle (>=v1.3.1): From auto-generated recipe
  - Configuring symfony/security-bundle (>=v4.1.7): From auto-generated recipe
  - Configuring symfony/swiftmailer-bundle (>=v3.2.4): From auto-generated recipe
  - Configuring symfony/web-profiler-bundle (>=v4.1.7): From auto-generated recipe
  - Configuring symfony/twig-bundle (>=v4.1.7): From auto-generated recipe
  - Configuring symfony/monolog-bundle (>=v3.3.1): From auto-generated recipe
  - Configuring symfony/debug-bundle (>=v4.1.7): From auto-generated recipe
  - Configuring symfony/maker-bundle (>=v1.9.0): From auto-generated recipe
  - Configuring symfony/web-server-bundle (>=v4.1.7): From auto-generated recipe

Some files may have been created or updated to configure your new packages.
Please review, edit and commit them: these files are yours.

  [Composer\Downloader\TransportException]
  The "https://flex.symfony.com/versions.json" file could not be downloaded: failed to open stream: Connection refused

Je précise que c'est la première fois que j'installe symfony et que malgré mes recherches sur google je n'ai pas trouvé d'informations sur cet erreur précise ou sur comment la résoudre.

Merci

3 réponses


Lartak
Réponse acceptée

Bonjour.
C'est plutôt logique que tu aies ce problème.
Pour commencer, tu ne dois pas utiliser composer pour créer un projet sur un serveur en ligne, sur un serveur en ligne tu dois y transférer le projet terminé.
Ou alors, si tu veux le faire en deux étapes, c'est à dire, créer ton projet en local puis une fois fini, recréer un projet en ligne via composer et y transférer les fichiers spécifiques de ton projet vers le serveur en ligne, lorsque tu utilises composer pour créer le projet sur le serveur en ligne, il te faut ajouter --no-dev dans ta commande, soit par exemple php composer.phar create-project --no-dev symfony/website-skeleton symfony1.
Il ne faut jamais installer les dépendances de développement sur un serveur en ligne, soit en mode de production.
Car si tu as cette erreur, c'est parce que tu y installe des dépendances qui sont spécifiques à un environnement de développement.

Mike Descamps

Le problème c'est que c'est sur un serveur mutualisé mais j'ai envoyé une demande d'assistance à OVH donc quand j'aurais des nouvelles je viendrait pour donner leur réponse
Merci quand même

Mike Descamps

Bonjour,
Ok je comprend maintenant, merci Lartak pour ta réponse