Bonjour,

J'ai récemment fais une modification et publier mais depuis jais ce message derreur The change you wanted was rejected.

Edit: Personne sait comment résoudre ce problème ?

15 réponses


TheGrinch
Auteur
Réponse acceptée

C'est bon problème résolu plus de message

Personne ?

Bonsoir.
Tu devrais donner plus de précisions sur le problème et son contexte si tu veux que des personnes puissent t'aider, car là c'est beaucoup trop vague.

bah j'ai modifié quelque page et depuis impossible d'editer ou d'ajouter des articles et sa le fais que sur chrome et Firefox sur edge ou ie sa le fais pas

voici l'url si ça peut aider

Pour ma part l'edition et ajout d'article fonctionne via ton lien, esque c'est moi ou as tu trouvé la solution ?

Non je n'ai pas trouvé la solution toujour ce problème.

j'ai ce message sur Chromium

je vient de retester sur FireFox plus de problème

Le soucis viendrai de chromium ?
J'ai cherché sur internet et j'ai troucé ceci : https://github.com/gitlabhq/gitlab-public-wiki/wiki/Trouble-Shooting-Guide#cant-verify-csrf-token-authenticitycant-get-past-login-pageredirected-to-login-page
Je pense que le problème vien de ton certificat ssl, chromium as peut-être du mal avec (algorithm de cryptage illisible pour lui ?)

Si tu utilise nginx comme serveur web, essaye d'ajouter cette ligne dans ton location :

proxy_set_header X-Forwarded-Ssl     on;

tfacon je vais faire une réinstallation parce que jai essayer de redémarrer mon VPS mais le site est plus accessible

Serait-il possible d'avoir la trace (log) de l'erreur en question?

Oui voici les error du log de nginx

2016/11/03 01:04:20 [error] 1539#1539: *74 connect() to unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock failed (111: Connection refused) while connecting to upstream, client: 176.132.81.51, server: tutos.be, request: "GET / HTTP/1.1", upstream: "http://unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock:/", host: "tutos.be"
2016/11/03 01:04:20 [error] 1539#1539: *74 connect() to unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock failed (111: Connection refused) while connecting to upstream, client: 176.132.81.51, server: tutos.be, request: "GET / HTTP/1.1", upstream: "http://unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock:/", host: "tutos.be"
2016/11/03 01:04:21 [error] 1539#1539: *74 connect() to unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock failed (111: Connection refused) while connecting to upstream, client: 176.132.81.51, server: tutos.be, request: "GET / HTTP/1.1", upstream: "http://unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock:/", host: "tutos.be"
2016/11/03 01:04:21 [error] 1539#1539: *74 connect() to unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock failed (111: Connection refused) while connecting to upstream, client: 176.132.81.51, server: tutos.be, request: "GET / HTTP/1.1", upstream: "http://unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock:/", host: "tutos.be"
2016/11/03 01:04:27 [error] 1539#1539: *74 connect() to unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock failed (111: Connection refused) while connecting to upstream, client: 176.132.81.51, server: tutos.be, request: "GET / HTTP/1.1", upstream: "http://unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock:/", host: "tutos.be"
2016/11/03 02:40:10 [error] 1539#1539: *95 connect() to unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock failed (111: Connection refused) while connecting to upstream, client: 66.249.76.44, server: tutos.be, request: "GET / HTTP/1.1", upstream: "http://unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock:/", host: "tutos.be"
2016/11/03 06:13:05 [error] 1539#1539: *119 connect() to unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock failed (111: Connection refused) while connecting to upstream, client: 66.249.76.57, server: tutos.be, request: "GET /profil/7 HTTP/1.1", upstream: "http://unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock:/profil/7", host: "www.tutos.be"
2016/11/03 06:17:58 [error] 1539#1539: *122 connect() to unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock failed (111: Connection refused) while connecting to upstream, client: 184.105.247.196, server: tutos.be, request: "GET / HTTP/1.1", upstream: "http://unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock:/", host: "151.80.57.119"
2016/11/03 06:23:14 [error] 1539#1539: *128 connect() to unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock failed (111: Connection refused) while connecting to upstream, client: 66.249.76.47, server: tutos.be, request: "GET /posts HTTP/1.1", upstream: "http://unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock:/posts", host: "tutos.be"
2016/11/03 08:34:57 [error] 1539#1539: *137 connect() to unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock failed (111: Connection refused) while connecting to upstream, client: 66.249.64.178, server: tutos.be, request: "GET / HTTP/1.1", upstream: "http://unix:/home/user/tutos.be/shared/tmp/sockets/puma.sock:/", host: "tutos.be"

Tu as bien mis un chmod 777 au dossier tmp ?

Bonsoir,

bon j'ai fais une réinstallation et mis le dossier tmp en 777 tout fonctionne pour le moment.

le dossier tmp doit-être accessible en 777 si je me trompe pas pour que ça fonctionne correctement